høyre|miniatyr|Tabelloversikt av iCalendar-komponenter og deres egenskaper iCalendar, formelt kjent som Internet Calendaring and Scheduling Core Object Specification, er en spesifikasjon og mediatype som lar brukere opprette og utveksle kalenderinformasjon og planlegging av hendelser, gjøremål og journaloppføringer gjennom en fil med filetternavnet .ics (grunnleggende), mens varianten med filetternavnet .ifb også gir informasjon om man er ledig eller opptatt (tilgjengelighetsinformasjon). iCalendar-data har Multipurpose Internet Mail Extensions (MIME) -innholdstypen tekst / kalender.

Ved hjelp av støttet programvare, for eksempel en epostleser eller digital kalender, kan mottakere av en iCalendar-fil enkelt svare avsenderen eller foreslå et annen dato eller møtetidspunkt. Filformatet er spesifisert i internett-standarden RFC 5545 for utveksling av kalenderdata.

iCalendar støttes og brukes i dag av mange applikasjoner, inkludert Google-kalender, Apple Kalender (tidligere kalt iCal), HCL Domino (tidligere IBM Notes og deretter Lotus Notes), Yahoo! Calendar, GNOME Evolution, eM Client, Lightning-utvidelsen for Mozilla Thunderbird og SeaMonkey, og delvis av Microsoft Outlook og Novell GroupWise.

iCalendar er designet for å være uavhengig av transportprotokollen. For eksempel kan visse hendelser sendes via tradisjonell epost, eller hele kalenderfiler kan deles og redigeres ved hjelp av en WebDav-tjener eller SyncML. Enkle vevtjenere (som bare bruker HTTP-protokollen) brukes ofte til å distribuere iCalendar-data om en hendelse og for å publisere når en person er opptatt. Utgivere kan bygge inn iCalendar-data på websider ved hjelp av hCalendar, en 1:1 mikroformat-representasjon av iCalendar i semantisk XHTML og HTML.

Historie I 1998 ble iCalendar opprettet av Arbeidsgruppen for kalender- og tidsplanlegging (Calendaring and Scheduling Working Group) i Internet Engineering Task Force under ledelse av Anik Ganguly fra Open Text Corporation og utviklerne Frank Dawson fra Lotus Development Corporation og Derik Stenerson fra Microsoft. iCalendar er sterkt basert på tidligere vCalendar utviklet av Internet Mail Consortium (IMC). RFC 5545 erstattet RFC 2445 i 2009 september tok deretter over som definisjonen på standarden.

Design Som standard bruker iCalendar UTF-8 tegnsettet. Andre tegnsett kan spesifiseres ved hjelp av MIME-parameteren "charset" (dersom transportmetoden som brukes støtter MIME, for eksempel epost eller HTTP).

Hver linje avsluttes med CR+LF (heksadesimalt: 0D0A). Hver linje bør begrenses til en lengde på 75 oktetter (ikke tegn). Der hvor et dataelement er for langt til å passe på én enkelt linje kan man fortsette på følgende linjer ved å starte fortsettelseslinjene med et mellomrom (i hex: 20) eller et tabulatortegn (i hex: 09).

Faktiske linjematinger i dataelementer er kodet som en bakstrek etterfulgt av bokstaven n eller N (bitene 5C 6E eller 5C 4E i UTF-8).

Begrensninger og fremtid iCalendar-formatet er designet for å overføre kalenderbaserte data som for eksempel hendelser, og beskriver med vilje ikke hva som skal gjøres med disse dataene. Dermed kan det være nødvendig med annen programmering for å automatisere hvilke handlinger som skal foretas basert på disse dataene.

iCalendar er ment å «gi definisjonen av et felles format for åpen deling av kalender- og planleggingsinformasjon over internett». Mens det er god støtte i iCalendar for for de fleste vanlige funksjonene fører imidlertid noen avanserte funksjoner til problemer. For eksempel støtter de fleste epost- og kalender-leverandørene ikke Journals-funksjonen (VJOURNAL). VTODO har også hatt konverteringsproblemer.

iCalendar kalender er heller ikke kompatibel med enkelte ikke-gregorianske kalendere så som månekalenderne brukt i Israel og Saudi-Arabia.

Notatet Calendar Access Protocol (RFC 4324) var et første forsøk på et universelt system for å lage sanntidskalendere, men ble til slutt forlatt. Istedet fikk iCalendar noen adopsjon for slike formål med ad hoc-utvidelser som GroupDAV og CalDAV som har stått frem som uformelle standarder har fått noe adopsjon i både klient- og tjener-programvarepakker.

I 2011 januar avsluttet IETF Calendaring and Scheduling Working Group (kalt «ietf-calsify WG») sitt første forsøk på å forenkle iCalendar-standardene uten at resultatenene ble tatt i bruk. Arbeidet ble deretter plukket opp og fortsatt av IETF Calendaring Extensions Working Group (kalt «ietf-calext WG»).

Tekniske data Kjerneobjekt Toppnivå-elementet i iCalendar heter Calendaring and Scheduling Core Object, og er en samling av kalender- og planleggingsinformasjon. Vanligvis vil denne informasjonen bestå av et enkelt iCalendar-objekt, men imidlertid kan også flere iCalendar-objekter grupperes sammen.

Den første linjen må være BEGIN:VCALENDAR, og den siste linjen må være END:VCALENDAR. Innholdet mellom disse linjene kalles "icalbody" (kroppen). Kroppen må inneholde kalenderegenskapene "PRODID" og "VERSION". I tillegg må den inneholde minst én kalenderkomponent. Merk også at mens denne artikkelen ofte bruker en e-poststilen UID (unik identifikator) så anses dette nå som dårlig praksis, og en universell unik identifikator (UUID) bør brukes istedet.

VERSION er 2.0 for gjeldende iCalendar-format per 2016. VERSION: 1.0 ble brukt til å spesifisere at dataene er i det gamle vCalendar-formatet.

Kroppen til iCalendar-objektet (icalbody) inneholder enkeltlinjers Calendar Properties ("kalenderegenskaper") som gjelder for hele kalenderen, samt en eller flere blokker med flere linjer som hver definerer en Calendar Component ("kalenderkomponent") som for eksempel en hendelse, journaloppføring, alarm eller en av de andre typene som beskrevet nedenfor. Her følger er et enkelt eksempel på et iCalendar-objekt med én enkelt kalender som inneholder én enkelt Calendar Component, et arrangement kalt «Fest i anledning den franske nasjonaldag» som starter 1997 juli den 14. klokken 17:00 og slutter klokken 16:00 neste morgen.BEGIN:VCALENDAR VERSION:2.0 PRODID:-//hacksw/handcal//NONSGML v1.0//EN BEGIN:VEVENT UID:[email protected] DTSTAMP:19970714T170000Z ORGANIZER;CN=Kari Nordmann:MAILTO:[email protected] DTSTART:19970714T170000Z DTEND:19970715T040000Z SUMMARY:Fest i anledning den franske nasjonaldagen GEO:59.9130;10.7400 END:VEVENT END:VCALENDAR

Dato- og tidsformat

Den vanligste representasjonen av dato og klokkeslett er et tz-tidsstempel, for eksempel 20010911T124640Z med formatet <år (4 sifre)><måned (2)><dag (2)>T<time (2)><minutt (2)><sekund (2)>Z for en total fast lengde på 16 tegn. Z indikerer her bruk av UTC (som i sin tid refererte til "zulu-tidssonen"). Når man bruker DTSTART og DTEND -egenskapene er starttider inkluderende, mens sluttider ikke er det. Dette muliggjør at en sluttiden til en hendelse kan være den samme som starten av en påfølgende hendelses uten at disse hendelsene overlapper hverandre og potensielt skaper (falske) planleggingskonflikter.

Hendelser (VEVENT) VEVENT beskriver en hendelse som har en planlagt tidsperiode i en kalender. Vanligvis når en bruker godtar kalenderhendelsen vil dette føre til at tiden blir ansett som opptatt. En VEVENT kan inkludere en VALARM som tillater en alarm. Slike hendelser har en DTSTART som setter en starttid, og en DTEND som setter en sluttid. Dersom kalenderhendelsen gjentar seg vil DTSTART sette opp starttidspunktet for den første hendelsen.

Eksempel på en VALARM-kode (påminnelse 1 dag før): BEGIN:VALARM TRIGGER:-PT1440M ACTION:DISPLAY DESCRIPTION:Reminder END:VALARMVEVENT brukes også til kalenderhendelser uten en bestemt tid, som for eksempel jubileer og daglige påminnelser. Dersom brukeren må sende inn en avbestilling for en hendelse skal UID være den samme som den opprinnelige hendelsen, og komponentegenskapene skal settes til avbryt. METHOD:CANCEL STATUS:CANCELLED

For å sende en UPDATE (oppdatering) for et arrangement bør UID samsvare med den originale UID-en. Den andre komponentegenskapen som skal settes er: SEQUENCE:<Num of Update>For den første oppdateringen vil dermed:SEQUENCE:1I Microsoft Outlook tilsvarer SUMMARY med "emne"-oppføringen i "avtaleskjemaet", og DESCRIPTION til den beskrivende teksten under den. I tillegg krevde Outlook 2002 og Outlook 2003 en UID og en DTSTAMP.

Gjøremål (VTODO) VTODO beskriver et gjøremål, altså et handlingselement eller en oppgave.

Ikke alle kalenderprogrammer anerkjenner VTODO-elementer. Spesifikt vil ikke Outlook eksportere oppgaver som VTODO-elementer, og ignorerer VTODO-elementer i importerte kalendere.

Følgende er et eksempel på en oppgave som forfaller 1998 april 15. En lydalarm er spesifisert for å minne kalenderbrukeren ved middagstid (kl. 12:00) dagen før oppgaven forventes å være fullført, og gjenta hver time opptil fire ganger til. SEQUENCE-elementet viser at denne oppgaven har blitt endret to ganger siden den ble opprettet. BEGIN:VCALENDAR VERSION:2.0 PRODID:-//ABC Corporation//NONSGML My Product//EN BEGIN:VTODO DTSTAMP:19980130T134500Z SEQUENCE:2 UID:[email protected] DUE:19980415T235959 STATUS:NEEDS-ACTION SUMMARY:Sende inn skattemelding BEGIN:VALARM ACTION:AUDIO TRIGGER:19980414T120000 ATTACH;FMTTYPE=audio/basic:http://example.com/pub/audio- files/ssbanner.aud REPEAT:4 DURATION:PT1H END:VALARM END:VTODO END:VCALENDAR

Journalføring (VJOURNAL) VJOURNAL er en journaloppføring. De legger ved en beskrivende tekst til en bestemt kalenderdato, og kan brukes til å registrere en daglig oversikt over aktiviteter eller prestasjoner, eller beskrive fremgang relatert til en gjøremålsoppføring. En "VJOURNAL"-kalenderkomponent tar ikke opp tid på en kalender, og har dermed ingen effekt på ledig eller opptatt tid (akkurat som TRANSPARENT-oppføringer). I praksis er det få programmer som støtter VJOURNAL-oppføringer, men det finnes eksempler: Plum Canary sin Chirp-programvare bruker VTODO og VJOURNAL sammen. VJOURNAL støttes også av KOrganizer fra KDE Desktop og Evolution fra GNOME desktop.

Følgende er et eksempel på en journaloppføring: BEGIN:VCALENDAR VERSION:2.0 PRODID:-//ABC Corporation//NONSGML My Product//EN BEGIN:VJOURNAL DTSTAMP:19970324T120000Z UID:[email protected] ORGANIZER:MAILTO:[email protected] STATUS:DRAFT CLASS:PUBLIC CATEGORIES:Project Report, XYZ, Weekly Meeting DESCRIPTION:Project xyz Review Meeting Minutes\n Agenda\n1. Review of project version 1.0 requirements.\n2. Definition of project processes.\n3. Review of project schedule.\n Participants: John Smith\, Jane Doe\, Jim Dandy\n-It was decided that the requirements need to be signed off by product marketing.\n-Project processes were accepted.\n -Project schedule needs to account for scheduled holidays and employee vacation time. Check with HR for specific dates.\n-New schedule will be distributed by Friday.\n- Next weeks meeting is cancelled. No meeting until 3/23. END:VJOURNAL END:VCALENDAR(Merk: Dette eksemplet er hentet fra RFC 2445 med korreksjonen at ordet CATEGORIES ble endret fra CATEGORY som var en feil i den opprinnelige RFC-en.)

Ledig/opptatt tid (VFREEBUSY) VFREEBUSY kan enten være en forespørsel om ledig eller opptatt tid, et svar på en forespørsel, eller en publisert mengde med opptatt tid.

Følgende er et eksempel på publisert informasjon om opptatt tid: BEGIN:VCALENDAR VERSION:2.0 PRODID:-//RDU Software//NONSGML HandCal//EN BEGIN:VFREEBUSY DTSTAMP:20151013T080000Z UID:[email protected] ORGANIZER:MAILTO:[email protected] DTSTART:19980313T141711Z DTEND:19980410T141711Z FREEBUSY:19980314T233000Z/19980315T003000Z FREEBUSY:19980316T153000Z/19980316T163000Z FREEBUSY:19980318T030000Z/19980318T040000Z URL:http://www.example.com/calendar/busytime/jsmith.ifb END:VFREEBUSY END:VCALENDAR

Andre komponenttyper Andre komponenttyper inkluderer VAVAILABILITY, VTIMEZONE (tidssone) og VALARM (alarm). Enkelte komponenter kan inneholde andre komponenter (VALARM er ofte inkludert i andre komponenter).

Distribuering av oppdateringer